5.2. Database

The recommended database is MySQL 5.0.

5.2.1. MySQL 4.1 or MySQL 5.0

ProsePoint supports MySQL 4.1 or higher, though MySQL 5.0 is recommended.

ProsePoint makes use of some features not available on some inexpensive hosting plans so please check that your host allows database accounts with the following rights:

SELECT, INSERT, UPDATE, DELETE, CREATE, DROP, INDEX, ALTER, CREATE TEMPORARY TABLES, LOCK TABLES

Note

If your system/host is running MySQL 4.1 or newer and you receive the error "Client does not support authentication protocol requested by server", address the problem by following the instructions provided by MySQL AB. There is a minor OS issue with some MySQL 5+ installations primarily on Windows but affecting some versions of Unix/Linux as well.

5.2.2. PostgreSQL 7.4 or higher

ProsePoint supports PostgreSQL 7.4 or higher, although it is not as widely tested.