ProsePoint Express: hosted newspaper website content management software

images not showing up on published stories

  • strict warning: Non-static method view::load() should not be called statically in /home/prosepoint.org/bzr/public_html/profiles/prosepoint/modules/views/views.module on line 879.
  • strict warning: Declaration of views_handler_argument::init() should be compatible with views_handler::init(&$view, $options) in /home/prosepoint.org/bzr/public_html/profiles/prosepoint/modules/views/handlers/views_handler_argument.inc on line 0.
  • strict warning: Declaration of views_handler_filter::options_validate() should be compatible with views_handler::options_validate($form, &$form_state) in /home/prosepoint.org/bzr/public_html/profiles/prosepoint/modules/views/handlers/views_handler_filter.inc on line 0.
  • strict warning: Declaration of views_handler_filter::options_submit() should be compatible with views_handler::options_submit($form, &$form_state) in /home/prosepoint.org/bzr/public_html/profiles/prosepoint/modules/views/handlers/views_handler_filter.inc on line 0.
  • strict warning: Declaration of views_handler_filter_node_status::operator_form() should be compatible with views_handler_filter::operator_form(&$form, &$form_state) in /home/prosepoint.org/bzr/public_html/profiles/prosepoint/modules/views/modules/node/views_handler_filter_node_status.inc on line 0.
  • strict warning: Non-static method view::load() should not be called statically in /home/prosepoint.org/bzr/public_html/profiles/prosepoint/modules/views/views.module on line 879.
  • strict warning: Declaration of views_handler_filter_boolean_operator::value_validate() should be compatible with views_handler_filter::value_validate($form, &$form_state) in /home/prosepoint.org/bzr/public_html/profiles/prosepoint/modules/views/handlers/views_handler_filter_boolean_operator.inc on line 0.
  • strict warning: Declaration of date_api_filter_handler::value_validate() should be compatible with views_handler_filter::value_validate($form, &$form_state) in /home/prosepoint.org/bzr/public_html/profiles/prosepoint/modules/date/includes/date_api_filter_handler.inc on line 0.
  • strict warning: Non-static method view::load() should not be called statically in /home/prosepoint.org/bzr/public_html/profiles/prosepoint/modules/views/views.module on line 879.
  • strict warning: Declaration of views_plugin_row::options_validate() should be compatible with views_plugin::options_validate(&$form, &$form_state) in /home/prosepoint.org/bzr/public_html/profiles/prosepoint/modules/views/plugins/views_plugin_row.inc on line 0.
  • strict warning: Declaration of views_plugin_row::options_submit() should be compatible with views_plugin::options_submit(&$form, &$form_state) in /home/prosepoint.org/bzr/public_html/profiles/prosepoint/modules/views/plugins/views_plugin_row.inc on line 0.
4 replies [Last post]
ibsous
User offline. Last seen 5 years 52 weeks ago. Offline
Joined: 11/09/2011
Posts:
hi,

i'm inserting images in a story post using the insert image from the visual editor, the images do show up on the visual editor when i upload them, but then fail to show up when i save and publish the post.

instead, the published post shows part of the images html code:
e.g: " align="none" link="/image/fileName" nid="84" preset="medium" teaser="0"]

strangely, the same post have other images that were uploaded in the same manner, and which appear before and after the images which don't show up, but these show up fine on both the visual editor and the saved publish story.

i have seen these two previous threads but did not find them useful
http://www.prosepoint.org/node/772
http://www.prosepoint.org/node/784

the html code uses the <pp_img>  tag, which is generated automatically and which i didn't edit.

it looks like this: <pp_imgtype="node" title="someTitle" caption="someCaption" align="none" link="/image/fileName" nid="88" preset="large" teaser="0"> </pp_img>

the input format field has the "filtered html" field checked by default.

i'm working on Firefox.

any thoughts?

many thanks,
ibsous.
beng
User offline. Last seen 4 years 31 weeks ago. Offline
Joined: 27/02/2009
Posts:
Hi, Some thoughts, but

Hi,

Some thoughts, but nothing definitive ...

The <pp_img> tags are inserted by the Visual editor as a result of image insert. I can only suggest something has gone wrong when they are translated into html code during node display.

> it looks like this: <pp_imgtype="node"

There should be a space after pp_img. Can you confirm there is no space for your case?

Furthermore, the visual editor and ProsePoint don't use square brackets when translating the pp_img tags.

These two bits suggest that something's not quite right with your input filters. Have you added any modules which add additional filters? Perhaps something is clashing and corrupting the <pp_img> tag before ProsePoint gets to it?

ibsous
User offline. Last seen 5 years 52 weeks ago. Offline
Joined: 11/09/2011
Posts:
thanks for your answer beng,

thanks for your answer beng, that was helpful, and apologies for my late reply.

it turned out the issue was with using the square braket character " [ " inside the caption text. the images loaded fine when i removed the character from the caption.

is there actually a way of including the square braket character inside the caption without causing this problem?

i'm using the square brakets for referencing, e.g. Figure 1. some text describing work by x [6], where [6] refers to a citation at the end of the article.

i could of course choose a different format for citations inside the text, but iw ould rather not because that would basically go agaist the formatting scheme used in my website publication.

any ideas would be appreciated.

thanks.

beng
User offline. Last seen 4 years 31 weeks ago. Offline
Joined: 27/02/2009
Posts:
...

Hi,

At the moment, I can't think of anything. I've tried using entity encoding such as &#91; for left square bracket in the html editor, but that doesn't work.

ibsous
User offline. Last seen 5 years 52 weeks ago. Offline
Joined: 11/09/2011
Posts:
yes, i tried that too. thanks
yes, i tried that too. thanks anyway, will post back if i figure a way around this.

(btw, i'm new to both prosepoint and this forum, and find it great that your replies are prompt. thanks for that.)

regards,