ProsePoint 0.17

  • strict warning: Non-static method view::load() should not be called statically in /home/prosepoint.org/bzr/public_html/profiles/prosepoint/modules/views/views.module on line 879.
  • strict warning: Declaration of views_handler_argument::init() should be compatible with views_handler::init(&$view, $options) in /home/prosepoint.org/bzr/public_html/profiles/prosepoint/modules/views/handlers/views_handler_argument.inc on line 0.
  • strict warning: Declaration of views_handler_filter::options_validate() should be compatible with views_handler::options_validate($form, &$form_state) in /home/prosepoint.org/bzr/public_html/profiles/prosepoint/modules/views/handlers/views_handler_filter.inc on line 0.
  • strict warning: Declaration of views_handler_filter::options_submit() should be compatible with views_handler::options_submit($form, &$form_state) in /home/prosepoint.org/bzr/public_html/profiles/prosepoint/modules/views/handlers/views_handler_filter.inc on line 0.
  • strict warning: Declaration of views_handler_filter_node_status::operator_form() should be compatible with views_handler_filter::operator_form(&$form, &$form_state) in /home/prosepoint.org/bzr/public_html/profiles/prosepoint/modules/views/modules/node/views_handler_filter_node_status.inc on line 0.
  • strict warning: Non-static method view::load() should not be called statically in /home/prosepoint.org/bzr/public_html/profiles/prosepoint/modules/views/views.module on line 879.
  • strict warning: Declaration of views_handler_filter_boolean_operator::value_validate() should be compatible with views_handler_filter::value_validate($form, &$form_state) in /home/prosepoint.org/bzr/public_html/profiles/prosepoint/modules/views/handlers/views_handler_filter_boolean_operator.inc on line 0.
  • strict warning: Declaration of date_api_filter_handler::value_validate() should be compatible with views_handler_filter::value_validate($form, &$form_state) in /home/prosepoint.org/bzr/public_html/profiles/prosepoint/modules/date/includes/date_api_filter_handler.inc on line 0.
  • strict warning: Non-static method view::load() should not be called statically in /home/prosepoint.org/bzr/public_html/profiles/prosepoint/modules/views/views.module on line 879.
  • strict warning: Declaration of views_plugin_row::options_validate() should be compatible with views_plugin::options_validate(&$form, &$form_state) in /home/prosepoint.org/bzr/public_html/profiles/prosepoint/modules/views/plugins/views_plugin_row.inc on line 0.
  • strict warning: Declaration of views_plugin_row::options_submit() should be compatible with views_plugin::options_submit(&$form, &$form_state) in /home/prosepoint.org/bzr/public_html/profiles/prosepoint/modules/views/plugins/views_plugin_row.inc on line 0.
Release Notes

This is a security release of ProsePoint addressing an upstream vulnerability SA-CONTRIB-2009-013 (http://drupal.org/node/406520) and also includes a number of other minor bugfixes and improvements. All users are advised to upgrade to this version.

Security Update

This release of ProsePoint fixes an upstream vulnerability SA-CONTRIB-2009-013 CCK - Cross site scripting (http://drupal.org/node/406520).

Other Changes

There are some other minor bugfixes and improvements. For the full list of changes, please see the changelog.

There are newer versions of some upstream modules available, but these were not upgraded in this release of ProsePoint because they have not been tested fully. In particular, the latest Date module may require some additional integration.

Download

VersionDateSizeDownload
ProsePoint 0.17 19th March 2009 5729 KB prosepoint-0.17.tar.gz (md5)

Upgrading to ProsePoint 0.17

If upgrading from ProsePoint version 0.16, please use the general ProsePoint upgrade procedure in the user guide to upgrade to ProsePoint 0.17. A partial source code upgrade is sufficient.

If upgrading from ProsePoint versions 0.07 to 0.15, please use the general ProsePoint upgrade procedure in the user guide to upgrade to ProsePoint 0.17. A full source code upgrade is required.

Please do not upgrade directly to 0.17 from versions earlier than 0.07. You need to upgrade to an intermediate version first before upgrading to 0.17.

Comments

Latest version of Date module from Drupal is buggy.

Turns out the latest version of the Date module (6.x-2.0) from Drupal is buggy. It's a good thing I didn't spend too much time trying to incorporate it into ProsePoint 0.17.

If you don't know what I'm talking about, then there is no need to worry. ProsePoint 0.17 uses Date 6.x-2.0rc6 and that works fine.

If you do know what I'm talking about, then please don't upgrade to Drupal's Date module version 6.x-2.0. It will break your site.

You have been warned :)