ProsePoint 0.18

  • strict warning: Non-static method view::load() should not be called statically in /home/prosepoint.org/bzr/public_html/profiles/prosepoint/modules/views/views.module on line 879.
  • strict warning: Declaration of views_handler_argument::init() should be compatible with views_handler::init(&$view, $options) in /home/prosepoint.org/bzr/public_html/profiles/prosepoint/modules/views/handlers/views_handler_argument.inc on line 0.
  • strict warning: Declaration of views_handler_filter::options_validate() should be compatible with views_handler::options_validate($form, &$form_state) in /home/prosepoint.org/bzr/public_html/profiles/prosepoint/modules/views/handlers/views_handler_filter.inc on line 0.
  • strict warning: Declaration of views_handler_filter::options_submit() should be compatible with views_handler::options_submit($form, &$form_state) in /home/prosepoint.org/bzr/public_html/profiles/prosepoint/modules/views/handlers/views_handler_filter.inc on line 0.
  • strict warning: Declaration of views_handler_filter_node_status::operator_form() should be compatible with views_handler_filter::operator_form(&$form, &$form_state) in /home/prosepoint.org/bzr/public_html/profiles/prosepoint/modules/views/modules/node/views_handler_filter_node_status.inc on line 0.
  • strict warning: Non-static method view::load() should not be called statically in /home/prosepoint.org/bzr/public_html/profiles/prosepoint/modules/views/views.module on line 879.
  • strict warning: Declaration of views_handler_filter_boolean_operator::value_validate() should be compatible with views_handler_filter::value_validate($form, &$form_state) in /home/prosepoint.org/bzr/public_html/profiles/prosepoint/modules/views/handlers/views_handler_filter_boolean_operator.inc on line 0.
  • strict warning: Declaration of date_api_filter_handler::value_validate() should be compatible with views_handler_filter::value_validate($form, &$form_state) in /home/prosepoint.org/bzr/public_html/profiles/prosepoint/modules/date/includes/date_api_filter_handler.inc on line 0.
  • strict warning: Non-static method view::load() should not be called statically in /home/prosepoint.org/bzr/public_html/profiles/prosepoint/modules/views/views.module on line 879.
  • strict warning: Declaration of views_plugin_row::options_validate() should be compatible with views_plugin::options_validate(&$form, &$form_state) in /home/prosepoint.org/bzr/public_html/profiles/prosepoint/modules/views/plugins/views_plugin_row.inc on line 0.
  • strict warning: Declaration of views_plugin_row::options_submit() should be compatible with views_plugin::options_submit(&$form, &$form_state) in /home/prosepoint.org/bzr/public_html/profiles/prosepoint/modules/views/plugins/views_plugin_row.inc on line 0.
Release Notes

ProsePoint 0.18 has been released

This is a security release of ProsePoint addressing an upstream security vulnerability. All users are advised to upgrade to this version.

Security Update

This release of ProsePoint fixes an upstream vulnerability. Unfortunately, this vulnerability has not yet been given an indentifier (as of writing), but it is mentioned at http://drupal.org/node/420990.

Other Changes

There are some other minor bugfixes and improvements. For the full list of changes, please see the changelog.

There are newer versions of some upstream modules available, but these were not upgraded in this release of ProsePoint because they have not been tested fully. In particular, the latest Date module may require some additional integration.

Download

VersionDateSizeDownload
ProsePoint 0.18 4th April 2009 5739 KB prosepoint-0.18.tar.gz (md5)

Upgrading to ProsePoint 0.18

If upgrading from ProsePoint version 0.16 or 0.17, please use the general ProsePoint upgrade procedure in the user guide to upgrade to ProsePoint 0.18. A partial source code upgrade is sufficient.

If upgrading from ProsePoint versions 0.07 to 0.15, please use the general ProsePoint upgrade procedure in the user guide to upgrade to ProsePoint 0.18. A full source code upgrade is required.

Please do not upgrade directly to 0.18 from versions earlier than 0.07. You need to upgrade to an intermediate version first before upgrading to 0.18.

After the upgrade, there is an additional configuration step required.

Please visit .../admin/content/node-type/media/display on your site. It should look like this:

 

Screenshot before

 

In the table shown, in the row Media file, please change the second and third drop-down boxes from fieldset to <Hidden> so that it looks like this:

 

Screenshot after

 

Then click Save at the bottom of the page.

Notes

ProsePoint 0.18 does not include the latest upstream Date module. Please do not update the Date module yourself. There are issues with upgrading and integration which need to be addressed.